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FrontPage is a Web authoring or Web publishing program. Web publishing programs put the power of Web site creation in everyone’s hands including those who don’t want to or don’t have time to learn HTML.

FrontPage enables you to create web pages using a familiar word processing like interface: you add and format text, pictures and other page content using menus and toolbar buttons, and FrontPage generates the corresponding HTML tags in the background. This method is known as What You See Is What You Get (WYSIWYG).

Creating Web Pages

1. Launch FrontPage Editor, a blank page is created by itself, where you type “My First Page” 

2. Choose “Heading 1” from the drop down menu and the whole line changes into big font. 

3. Press Enter.

4. Type “The <HTML> Tag”

5. Choose Heading 2 as in step 2.

6. Press Enter.

7. Type “HTML documents are platform-independent”

8. Highlight the phrase “platform-independent” and press the ”I” button in the Menu bar to get the italicized “platform-independent”

9. Press Enter.

10. Type “The <HTML> and </HTML> tags should be the first and the last element of the HTML document.

11. Highlight “HTML document” in the line and press the “B” button in the Menu bar to get the bolded “HTML document”.

12. To save the page, go to File>Save As

13. You will get a Save As window where you can give a name to the file, for example here we give the name “first” and save the file in your folder.

Now we will create a second page. For this:

14. Go to File>New>Page. This will give you a window where you will choose “Normal Page” and press “Ok” and you will get a new blank page.

15. Type “My Second Page” and choose “Heading 1” as in step 2.

16. Press Enter.

17. Type “HTML stands for Hyper Text Markup Language”

18. Highlight HTML and press the “U” button to under line HTML.
19. Press Enter.
20. Type “The following are some related terms:”
21. Press Enter.
22. Press “Bullets” button in Menu bar and you will see a bullet.
23. Type “Web site: A collection of World Wide Web documents, usually consisting of a home page.”
24. Press Enter.
25. Type “Home page: The home page is the main or the first page of the Web site.”
26. Press Enter.
27. Press the “Bullet” button in the Menu bar to remove the bullet from the line.
28. Now save the page as in the step 12 and give the name second.
Background color and image

1. Open the “first” file with FrontPage Editor.

2. Go to File>Properties and get a Page Properties window where you select the Background tab and from here choose aqua color from the Color Background drop down menu.

3. Press Ok and get the aqua background color in your first page.

4. Save the page.

5. Similarly open the “second” file and go to File>Properties and choose the Background tab.

6. Click on the Browse button, to get a new window from where you can choose your favorite image for background.

7. Press Ok.

8. And again press Ok.

9. Now your image is the background of your second page.

10. Save the page.

Link

Link or Hypertext link provides a path that connects one part of a World Wide Web document to another part of the same document, a different document, or another resource. A link usually appears as a uniquely colored word that you can click to be transported to another Web page. This is an important feature of HTML document.

Link between two pages

1. Open the “first“ File.

2. Add a text “Go to second” at the bottom of the page.

3. Click the right align button in the Menu bar.

4. Highlight the text.

5. Choose Insert>Hyperlink and you will get a window where you will define the path of the file to be linked.

6. Here you choose the “second” File so that the link points to the second file.

7. Save the page.

8. Now open the “first” file in the Browser. Click the “Preview in Browser” button in the Menu bar.

9. Move the cursor over the Hyper linked text (Go to second) so that the cursor changes into hand. Now when you click the mouse it will take you to the second page. Similarly, you can create a link from second page to the first page so that you can move from one page to another.

Link to Web Site

When you want a link from your web page directly to some web site itself, 

1. Open your “first” file in FrontPage Editor

2. Say you would like to make a link from the “first” page to TU home page. So type “TU” at the bottom of the page.

3. Highlight “TU”

4. Click the “Hyperlink” button in the Menu bar, you will get “Edit Hyperlink” window.

5. In URL field just type http://www.utibet.edu.cn
6. Save the page.

7. If you are connected to the Internet and if you click on “TU” it will take you to the TU home page.

In this way you can create hyper links either to your local files or URL.

Email Link

1. Type “Contact me” at the bottom of the “second” page

2. Highlight “Contact me”

3. Click the “Hyperlink” button in the Menu bar.

4. Type “mailto: your email address”

5. Save the page.

6. Open the page in the browser.

7. See what happens when you click on “Contact me”

Link to different parts of the same page

1. Click a “New Page” button in Menu bar in FrontPage Editor

2. Go to Insert>File and you will get a “select file” window

3. Select a “FrontPage.doc” file from CD-ROM (CD:\Manuals\FrontPage.doc)

4. Press “Open” and you will get whole the file content in your web page.

5. Place the cursor after (WYSIWYG), and press Enter

6. Type “Web Pages”

7. Press Enter

8. Type “Background”

9. Press Enter

10. Type “Different Kind of Links”

11. Place the cursor before “Creating Web Pages”

12. Go to Insert>Bookmark. You will get a “Bookmark” window.

13. Give any bookmark name in the bookmark name field, here we give 1

14. Press Ok

15. Similarly, give a bookmark name 2 for “Background Color and Image” and 3 for “Link”

16. Highlight “Web Pages”

17. Press “Hyperlink” button

18. Choose “1” from “Optional Bookmark” drop down menu

19. Press Ok

20. Similarly, 2 for “Background” and 3 for the “Different Kind of Links” So now you have created three links to the same page, when you click on “Web Pages”, it will take you to the “Creating Web Page” topics, similarly the links with “Background” and “Different kinds of Link” will take you to “Background Color and Image” topic and “Link” topic respectively.

21. Save the page with the name “third”

Table

Tables in HTML are just like the tables in word. A table is a way of organizing and presenting information visually by using rows and columns to group related elements. Now table is the cornerstone of Web layout.

Each work area in a table is called a cell. In HTML, tables are also used to present information visually in a way that simple paragraph break can’t do i.e. to create column of text, to integrate text and image, to create wide margins or sidebars, etc.

One way to create a table

1. With a page open in a Normal view, click the “Insert Table” button on the Standard toolbar. A little menu pops up onto your screen.
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2. Click one of the cells on this menu to indicate the size of the table you want to create. For instance if you want a table 3 cells wide by 3 rows long, you’d click the cell that’s three cells over from the left and three cells down on the table menu. When you click one, the table menu closes, and a blank table appears on the page.

All the default settings for tables are in effect for the table you just created. For instance, your table probably occupies 100% of the screen width and has 1-pixel border, but if you’ve changed these options, the last settings you defined will be the default settings. Later you will find out how to change settings to make the table look just the way you want to.

Another way to create a table

Now we’re going to use the Insert Table dialog box to create a simple table that has two columns and four rows, making eight cells in all. Just follow these steps:

1. Open FrontPage and create a new page as you normally would.

2. Go to Table>Insert Table and you will get “Insert Table” window
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3. In the size area of the dialog box, type 4 in Rows field, and 2 in Columns field.

4. In the layout section of the dialog box, you can choose to align your table to the left, center, or right of the page. To center your table on the page, select Center from the Alignment field.

5. Border size, Cell padding and Cell spacing will be discussed later.

6. One more field left is the option for the screen width of the table. To specify a width for the table, click the Specify Width checkbox to make the width option visible.

7. To make your table occupy a certain percentage of the window, click the In Percentage button to make it active. To specify the number of pixels your table should occupy, click the In Pixels button. Either way, type a number in the Specify Width text box. For example to make your table occupy 50% of the window, click the In Percent button and then type 50 in the Specify Width text box.

8. Click Ok and get table.

Placing Text and Images in a Table

You can type or paste text into a table. Just like you do onto any other part of a web page. Just click the insertion point where you want to type, and start typing. After that you can just use any font size, color or style to your text. And similarly as in any other part of the web, you can insert Image to any cell.

Just like you can change the alignment of text on a page, you can change the alignment of text and images in a table. On a standard web page, you can align text and paragraphs toward the left margin, the right margin or the middle of the page. In the context of a table cell, you have these option as well as the option of having text aligned with the top, bottom, baseline or middle of a cell.

To change the alignment of text in a cell, follow these steps:

1. Right click in the cell whose alignment you want to adjust. From the pop-up menu that appears, select Cell Properties and get the Cell Properties window.
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2. In the Layout are, click the Horizontal Alignment list box and choose an alignment (Left, Right or Center), click the Vertical Alignment list box to choose a vertical alignment (Top, Middle, Baseline or Bottom)

3. In the Background area, choose your desired color for the cell background or choose the background image for the cell.

Editing an Existing Table

So you put a table on your page, and all of a sudden you realize you need four columns, not three or you have a few rows to add. Perhaps you want the table to occupy more or less of the screen, or you want to turn off the border you initially put in or change the thickness of an existing border. There are several methods for changing a table you’ve already created. 

Changing the size of the table: You may want to define the size of your table, especially if you want it to occupy a particular percentage of the screen. Changing the size of the table you’ve already created is quire simple:

1. Right click on the table and choose the Table Properties, you will get a Table Properties window

2. Change the size in the Specify Width box

3. Press Ok.

Changing the alignment of the table: 

1. Right click on the table and choose Table Properties

2. In the alignment area select an alignment Left, Right or center

3. Press Ok

Adding Rows and Columns: 

1. Place the cursor where you want to add rows or column

2. From the menu bar, select Table>Insert Rows Or Columns and you will get Insert Rows or Columns window

3. Click either the Rows or Columns button. 

4. Type the number of Rows or Columns you want to add in the respective text box

5. Choose Above to place the rows above where the cell where your cursor is placed or below that OR Left or Right if you are adding the columns

6. Press Ok

Splitting Cell: Slitting the cells cuts a cell into pieces so that it forms its own set of mini-columns or rows. For that

1. Place the cursor in the cell that you want to split

2. From the menu bar, select Table>Split Cells. The Split Cells window will appears

3. In the window, click either Split into Columns button or the Split into Rows button, depending on your need

4. By default, a cell divides in two when you split it but if you’d like to choose another number, type it in the Number of Columns or Rows text box

5. Click Ok

Merging Cells: Splitting cell allows you to divide available space into smaller components. Merging the cells is just opposite to splitting.

1. Select the cells you want to merge by dragging the cursor

2. In the Menu bar, select Table>Merge Cells

Removing Rows and Columns: Sometimes you may need to remove the columns or rows.

1. Place the cursor in the cell, that you want to remove (the cell can be a part of the row or column you want to remove)

2. Go to Table>Select Cell or Row or Column depending upon your need

3. Press Delete Key in your Keyboard and the unwanted cells will be gone

The deletion of the cell or column or row will also delete the content in them.

Form

You can use forms in you web site to collect information or feed back from the visitors. We will use a form here for feedback in a very simple way.

1. Open FrontPage and go to File>New>Page and you will get a window from where you can choose number of readymade templates
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2. Choose Feedback form

3. Press Ok and you will get a feedback form as your page

4. Right click on the form and choose Form Properties to get the Form Properties Window

[image: image5.png]Whereto sore esults
& Bandid

Eie name: [ _Bowe
Emaleddess [

-

€ Sendto other

e e el

Optons.._ | _advanced.. | 0K Cancel |





5. Select Send to other option

6. Click the Option button and you will get new window
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7. In Action field, type mailto:your_email _address and press Ok

8. Save your form
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